Control Plane Slowness
Resolved
Aug 19, 2026 at 12:10pm UTC
We've resolved the issue, and are monitoring now
Affected services
Updated
Aug 19, 2026 at 12:00pm UTC
We've identified the root cause for the slowness. This looks like a cache overload issue on the control plane.
Affected services
Updated
Aug 19, 2026 at 10:40am UTC
Seeing higher spikes for slowness and failed requests again, we're triangulating the root cause,
Affected services
Updated
Aug 19, 2026 at 10:10am UTC
The trend is stabilizing, we're monitoring
Affected services
Created
Aug 19, 2026 at 10:00am UTC
We're seeing control plane slowness and dashboard failures.
Data plane queries to control plane (for non-cached queries) were failling intermittently.
Affected services